use strict;
my $str = 'dateto:\'2015-10-07 15:05\' xxxx datefrom:\'2015-10-09 15:05\' yyyy asdf';
my $regex = qr/'[^']*'(*SKIP)(*F)|\s+/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";