package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)'[^']*'(*SKIP)(*F)|\s+`)
var str = `dateto:'2015-10-07 15:05' xxxx datefrom:'2015-10-09 15:05' yyyy asdf`
var substitution = "\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}