#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/shop\/(?!best-buy)(?:\w+-)*earrings"
Local $sString = "/shop/earrings" & @CRLF & _
"/shop/yellow-gold-earrings" & @CRLF & _
"/shop/white-gold-earrings" & @CRLF & _
"/shop/rose-gold-earrings" & @CRLF & _
"" & @CRLF & _
"/shop/necklaces" & @CRLF & _
"/shop/yellow-gold-necklaces" & @CRLF & _
"/shop/white-gold-necklaces" & @CRLF & _
"/shop/rose-gold-necklaces" & @CRLF & _
"" & @CRLF & _
"/shop/best-buy-earrings" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")