import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/shop\\/(?!best-buy)(?:\\w+-)*earrings";
final String string = "/shop/earrings\n"
+ "/shop/yellow-gold-earrings\n"
+ "/shop/white-gold-earrings\n"
+ "/shop/rose-gold-earrings\n\n"
+ "/shop/necklaces\n"
+ "/shop/yellow-gold-necklaces\n"
+ "/shop/white-gold-necklaces\n"
+ "/shop/rose-gold-necklaces\n\n"
+ "/shop/best-buy-earrings\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}