re = /\/shop\/(?!best-buy)(?:\w+-)*earrings/m
str = '/shop/earrings
/shop/yellow-gold-earrings
/shop/white-gold-earrings
/shop/rose-gold-earrings
/shop/necklaces
/shop/yellow-gold-necklaces
/shop/white-gold-necklaces
/shop/rose-gold-necklaces
/shop/best-buy-earrings
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end