using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"abc (?:(?:(?!abc )[\s\S])*(mno))?(?:(?!abc )[\s\S])*";
string input = @"abc mno
abc random mno unknowable
abc unknowable mno random
abc random def unknowable
abc unknowable unknowable mno random";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}