re = /abc (?:(?:(?!abc )[\s\S])*(mno))?(?:(?!abc )[\s\S])*/
str = 'abc mno
abc random mno unknowable
abc unknowable mno random
abc random def unknowable
abc unknowable unknowable mno random'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end