import Foundation
let pattern = #"abc (?:(?:(?!abc )[\s\S])*(mno))?(?:(?!abc )[\s\S])*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
abc mno
abc random mno unknowable
abc unknowable mno random
abc random def unknowable
abc unknowable unknowable mno random
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)