$re = '/abc (?:(?:(?!abc )[\s\S])*(mno))?(?:(?!abc )[\s\S])*/';
$str = 'abc mno
abc random mno unknowable
abc unknowable mno random
abc random def unknowable
abc unknowable unknowable mno random';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);