#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^(?=(?:,*\d,*){1,4}$)|\G)\d*\K,(?!$)"
Local $sString = "9999" & @CRLF & _
"10,000" & @CRLF & _
"1,000,000" & @CRLF & _
"9,999" & @CRLF & _
"7,8" & @CRLF & _
"7,8,9" & @CRLF & _
"999,9," & @CRLF & _
",,,9"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")