const regex = /(?:^(?=(?:,*\d,*){1,4}$)|\G)\d*\K,(?!$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^(?=(?:,*\\d,*){1,4}$)|\\G)\\d*\\K,(?!$)', 'gm')
const str = `9999
10,000
1,000,000
9,999
7,8
7,8,9
999,9,
,,,9`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}