$re = '/(?:^(?=(?:,*\d,*){1,4}$)|\G)\d*\K,(?!$)/m';
$str = '9999
10,000
1,000,000
9,999
7,8
7,8,9
999,9,
,,,9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);