using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^(?=(?:,*\d,*){1,4}$)|\G)\d*\K,(?!$)";
string input = @"9999
10,000
1,000,000
9,999
7,8
7,8,9
999,9,
,,,9";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}