using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"start.*(\d{9}).*end";
string input = @"999993111 Example text start 999993112 999993113 999993114 Example text end 999993115";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}