package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)start.*(\d{9}).*end`)
var str = `999993111 Example text start 999993112 999993113 999993114 Example text end 999993115`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}