import re
regex = re.compile(r"start.*(\d{9}).*end", flags=re.MULTILINE)
test_str = "999993111 Example text start 999993112 999993113 999993114 Example text end 999993115"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")