re = /start.*(\d{9}).*end/m
str = '999993111 Example text start 999993112 999993113 999993114 Example text end 999993115'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end