using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(.{10,})(?=\1)";
string substitution = @"";
string input = @"Experience
Höweler+Yoon Architecture, LLP logo
Höweler+Yoon Architecture, LLPHöweler+Yoon Architecture, LLP
3 yrs 9 mos3 yrs 9 mos
Senior AssociateSenior Associate
Feb 2022 - Present · 3 mosFeb 2022 - Present · 3 mos
Boston, Massachusetts, United StatesBoston, Massachusetts, United States
-Assisted in documenting application for the Office's LEED-CI certification (anticipating Gold Level certification).-Responsible for researching and writing new content for Nexus' website. -Assisted in documenting application for the Office's LEED-CI certification (anticipating Gold Level certification).";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}