# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)(.{10,})(?=\1)"
test_str = ("Experience\n"
"Höweler+Yoon Architecture, LLP logo\n"
"Höweler+Yoon Architecture, LLPHöweler+Yoon Architecture, LLP\n"
"3 yrs 9 mos3 yrs 9 mos\n"
"Senior AssociateSenior Associate\n"
"Feb 2022 - Present · 3 mosFeb 2022 - Present · 3 mos\n"
"Boston, Massachusetts, United StatesBoston, Massachusetts, United States\n"
"-Assisted in documenting application for the Office's LEED-CI certification (anticipating Gold Level certification).-Responsible for researching and writing new content for Nexus' website. -Assisted in documenting application for the Office's LEED-CI certification (anticipating Gold Level certification).")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.