#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "" & @CRLF & _
"\{ # { character" & @CRLF & _
" (?: # non-capturing group" & @CRLF & _
" [^{}] # anything that is not a { or }" & @CRLF & _
" | # OR" & @CRLF & _
" (?R) # recurses the entire pattern" & @CRLF & _
" )* # previous group zero or more times" & @CRLF & _
"\} # } character" & @CRLF & _
""
Local $sString = "This is a funny text about stuff," & @CRLF & _
"look at this product {"action":"product","options":{...}}." & @CRLF & _
"More Text is to come and another JSON string" & @CRLF & _
"{"action":"review","options":{...}}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")