using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"
\{ # { character
(?: # non-capturing group
[^{}] # anything that is not a { or }
| # OR
(?R) # recurses the entire pattern
)* # previous group zero or more times
\} # } character
";
string input = @"This is a funny text about stuff,
look at this product {""action"":""product"",""options"":{...}}.
More Text is to come and another JSON string
{""action"":""review"",""options"":{...}}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}