#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([àa] usage de|idéal pour|zone mixte|propice au|doté de|composé (de|d'un)|lot \d{1} :) commerces?"
Local $sString = "REGEX_1 = (local commercial|locaux commerciaux)" & @CRLF & _
"" & @CRLF & _
"REGEX_2 = ((activit[eé]s?|entrep[oô]ts?|stockage|d[eé]p[oô]t) (ou|/|et de) commerce)" & @CRLF & _
"" & @CRLF & _
"REGEX_3 = ([àa] usage de|idéal pour|zone mixte|propice au|doté de|composé (de|d'un)|lot \d{1} :) commerces?" & @CRLF & _
"" & @CRLF & _
"REGEX_NOT =" & @CRLF & _
"(à proximité (commerces|" & @CRLF & _
"commerces? proche|" & @CRLF & _
"commerces? [aà] proximit[ée]| " & @CRLF & _
"[aà] proximit[ée](\s\w*)? des? commerces?)" & @CRLF & _
"" & @CRLF & _
"[Encapsuler xxx]" & @CRLF & _
"local commercial" & @CRLF & _
"locaux commerciaux" & @CRLF & _
"activité ou commerce" & @CRLF & _
"d'activité / commerce" & @CRLF & _
"entrepôts/bureaux/commerces" & @CRLF & _
"entrepôt et de commerce" & @CRLF & _
"à usage de commerce" & @CRLF & _
"zone mixte commerces" & @CRLF & _
"idéal pour commerces" & @CRLF & _
"en dépôt ou commerce" & @CRLF & _
"stockage / commerce" & @CRLF & _
"composé d'un commerce" & @CRLF & _
"doté de commerces" & @CRLF & _
"lot 1 : commerce" & @CRLF & _
"propice au commerce" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[NE PAS TENIR COMPTE]" & @CRLF & _
"à proximité (commerces, restaurants)" & @CRLF & _
"commerces? proche" & @CRLF & _
"commerces? à proximité " & @CRLF & _
"à proximité de commerces?" & @CRLF & _
"à proximité immédiate des commerces?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")