package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([àa] usage de|idéal pour|zone mixte|propice au|doté de|composé (de|d'un)|lot \d{1} :) commerces?`)
var str = `REGEX_1 = (local commercial|locaux commerciaux)
REGEX_2 = ((activit[eé]s?|entrep[oô]ts?|stockage|d[eé]p[oô]t) (ou|/|et de) commerce)
REGEX_3 = ([àa] usage de|idéal pour|zone mixte|propice au|doté de|composé (de|d'un)|lot \d{1} :) commerces?
REGEX_NOT =
(à proximité (commerces|
commerces? proche|
commerces? [aà] proximit[ée]|
[aà] proximit[ée](\s\w*)? des? commerces?)
[Encapsuler xxx]
local commercial
locaux commerciaux
activité ou commerce
d'activité / commerce
entrepôts/bureaux/commerces
entrepôt et de commerce
à usage de commerce
zone mixte commerces
idéal pour commerces
en dépôt ou commerce
stockage / commerce
composé d'un commerce
doté de commerces
lot 1 : commerce
propice au commerce
[NE PAS TENIR COMPTE]
à proximité (commerces, restaurants)
commerces? proche
commerces? à proximité
à proximité de commerces?
à proximité immédiate des commerces?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}