const regex = /^.+components\/|([^(\/.\s)]+)|(\/)|([^\s]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.+components\\\/|([^(\\\/.\\s)]+)|(\\\/)|([^\\s]+)', 'gm')
const str = `my-app/templates/components/one-directory/a-second-directory/third.hbs
my-app/templates/components/one-directory/third.hbs
my-app/templates/components/third.hbs
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}