$re = '/^.+components\/|([^(\/.\s)]+)|(\/)|([^\s]+)/m';
$str = 'my-app/templates/components/one-directory/a-second-directory/third.hbs
my-app/templates/components/one-directory/third.hbs
my-app/templates/components/third.hbs
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);