re = /^.+components\/|([^(\/.\s)]+)|(\/)|([^\s]+)/m
str = 'my-app/templates/components/one-directory/a-second-directory/third.hbs
my-app/templates/components/one-directory/third.hbs
my-app/templates/components/third.hbs
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end