// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.+components\/|([^(\/.\s)]+)|(\/)|([^\s]+)").unwrap();
let string = "my-app/templates/components/one-directory/a-second-directory/third.hbs
my-app/templates/components/one-directory/third.hbs
my-app/templates/components/third.hbs
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}