using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(.*?[0-9]{4}\)";
string input = @"Il était une fois (Perrault, vers 1665), une longue et belle histoire (Moi 2019). Cette citation ne devrait pas matcher (Moi).";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}