const regex = /\(.*?[0-9]{4}\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(.*?[0-9]{4}\\)', 'gm')
const str = `Il était une fois (Perrault, vers 1665), une longue et belle histoire (Moi 2019). Cette citation ne devrait pas matcher (Moi).`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}