package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(.*?[0-9]{4}\)`)
var str = `Il était une fois (Perrault, vers 1665), une longue et belle histoire (Moi 2019). Cette citation ne devrait pas matcher (Moi).`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}