import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\d*(?:([;,])(?:\\d+\\1)*\\d+)?\\]";
final String string = "[1,2,3,20,4]\n"
+ "[5;67;8;1;6]\n"
+ "[123]\n"
+ "[12,23]\n"
+ "[]\n"
+ "[1,2;4;5,6,7;8]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}