$re = '/\[\d*(?:([;,])(?:\d+\1)*\d+)?\]/m';
$str = '[1,2,3,20,4]
[5;67;8;1;6]
[123]
[12,23]
[]
[1,2;4;5,6,7;8]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);