re = /\[\d*(?:([;,])(?:\d+\1)*\d+)?\]/m
str = '[1,2,3,20,4]
[5;67;8;1;6]
[123]
[12,23]
[]
[1,2;4;5,6,7;8]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end