const regex = /\[\d*(?:([;,])(?:\d+\1)*\d+)?\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\d*(?:([;,])(?:\\d+\\1)*\\d+)?\\]', 'gm')
const str = `[1,2,3,20,4]
[5;67;8;1;6]
[123]
[12,23]
[]
[1,2;4;5,6,7;8]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}