package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(.+?)\.(C\d{1,2}))?(?:.*?(B\d{1,2}))?\.(?:.*?(42U|48U))?.*-(.+)$`)
var str = `This.is.Test.Nr.One.C01B01.42U.Rack.08-Datacenter1
Is.this.Nr.Two.C03B03.London.48U.Rack.04-Datacenter4
This.Number.Random.C02.Frankfurt.42U.Rack.12-Datacenter1
This.is.Random.Number.C08B01.Zuerich.Rack.01-Datacenter2
Is.this.Nr.Two.B03.London.48U.Rack.04-Datacenter4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}