$re = '/^(?:(.+?)\.(C\d{1,2}))?(?:.*?(B\d{1,2}))?\.(?:.*?(42U|48U))?.*-(.+)$/m';
$str = 'This.is.Test.Nr.One.C01B01.42U.Rack.08-Datacenter1
Is.this.Nr.Two.C03B03.London.48U.Rack.04-Datacenter4
This.Number.Random.C02.Frankfurt.42U.Rack.12-Datacenter1
This.is.Random.Number.C08B01.Zuerich.Rack.01-Datacenter2
Is.this.Nr.Two.B03.London.48U.Rack.04-Datacenter4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);