use strict;
my $str = 'This.is.Test.Nr.One.C01B01.42U.Rack.08-Datacenter1
Is.this.Nr.Two.C03B03.London.48U.Rack.04-Datacenter4
This.Number.Random.C02.Frankfurt.42U.Rack.12-Datacenter1
This.is.Random.Number.C08B01.Zuerich.Rack.01-Datacenter2
Is.this.Nr.Two.B03.London.48U.Rack.04-Datacenter4';
my $regex = qr/^(?:(.+?)\.(C\d{1,2}))?(?:.*?(B\d{1,2}))?\.(?:.*?(42U|48U))?.*-(.+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}