# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(.+?)\.(C\d{1,2}))?(?:.*?(B\d{1,2}))?\.(?:.*?(42U|48U))?.*-(.+)$"
test_str = ("This.is.Test.Nr.One.C01B01.42U.Rack.08-Datacenter1\n"
"Is.this.Nr.Two.C03B03.London.48U.Rack.04-Datacenter4\n"
"This.Number.Random.C02.Frankfurt.42U.Rack.12-Datacenter1\n"
"This.is.Random.Number.C08B01.Zuerich.Rack.01-Datacenter2\n"
"Is.this.Nr.Two.B03.London.48U.Rack.04-Datacenter4")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.