import re
regex = re.compile(r"^[,\h]+|\h*(,)(?:\h*,)+\h*|[,\h]+$", flags=re.MULTILINE)
test_str = ("GUWAHATI, TEZPUR, , BAMUNI HILLS, MAHABHAIRAB TEMPLE, AGNIGARH ,\n"
"GUWAHATI, TEZPUR , , BAMUNI HILLS,, MAHABHAIRAB TEMPLE, AGNIGARH,\n"
"GUWAHATI, , TEZPUR, , BAMUNI HILLS, MAHABHAIRAB TEMPLE, AGNIGARH")
subst = "$1 "
result = regex.sub(subst, test_str)
if result:
print(result)