re = /^[,\h]+|\h*(,)(?:\h*,)+\h*|[,\h]+$/m
str = 'GUWAHATI, TEZPUR, , BAMUNI HILLS, MAHABHAIRAB TEMPLE, AGNIGARH ,
GUWAHATI, TEZPUR , , BAMUNI HILLS,, MAHABHAIRAB TEMPLE, AGNIGARH,
GUWAHATI, , TEZPUR, , BAMUNI HILLS, MAHABHAIRAB TEMPLE, AGNIGARH'
subst = '$1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result