using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/uvod\/compare\?{1}product=car_insurance.*";
string input = @"https://www.chytryhonza.cz/uvod/compare?";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}