$re = '/\/uvod\/compare\?{1}product=car_insurance.*/';
$str = 'https://www.chytryhonza.cz/uvod/compare?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);