package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/uvod\/compare\?{1}product=car_insurance.*`)
var str = `https://www.chytryhonza.cz/uvod/compare?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}