re = /\/uvod\/compare\?{1}product=car_insurance.*/
str = 'https://www.chytryhonza.cz/uvod/compare?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end