#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bif\b\s*\(([\w\%\$\.]+\s*[\=\!\<\>].*[\&\|]?)?\)"
Local $sString = "if(%CDOCCM=" A")" & @CRLF & _
"if(CampoModif())" & @CRLF & _
"if(%MCRVINC=0")" & @CRLF & _
"if($SCR_P_U.CHAR3!="P")" & @CRLF & _
"if(%AUX1!=%ITPRED || %AUX2!=%MMOVIM)" & @CRLF & _
"if(%CBALCAO!="" && %NUMCONTA!="")" & @CRLF & _
"Limpar(%CCLIFUT)" & @CRLF & _
"Mandatorio(%CCLIFUT)" & @CRLF & _
"if(%CCLIFUT="")" & @CRLF & _
"if(%ZCLIENTE=0)" & @CRLF & _
"if (%FM7 != 0)" & @CRLF & _
"if($TRANS_ENCADEOU_U="TV19" && $cPRIMEIRAVOLTA_U=1)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")