const regex = /\bif\b\s*\(([\w\%\$\.]+\s*[\=\!\<\>].*[\&\|]?)?\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bif\\b\\s*\\(([\\w\\%\\$\\.]+\\s*[\\=\\!\\<\\>].*[\\&\\|]?)?\\)', 'g')
const str = `if(%CDOCCM=" A")
if(CampoModif())
if(%MCRVINC=0")
if(\$SCR_P_U.CHAR3!="P")
if(%AUX1!=%ITPRED || %AUX2!=%MMOVIM)
if(%CBALCAO!="" && %NUMCONTA!="")
Limpar(%CCLIFUT)
Mandatorio(%CCLIFUT)
if(%CCLIFUT="")
if(%ZCLIENTE=0)
if (%FM7 != 0)
if(\$TRANS_ENCADEOU_U="TV19" && \$cPRIMEIRAVOLTA_U=1)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}