package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\\[\d\w]+ (?<InvoiceID>\d+)[ ]*(?<ExtraInfo>.*)\.(?<Ext>.*)$`)
var str = `I:\ARInvoices\COMPANY1\Unused 39458 ExtraInfo.pdf
I:\ARInvoices\COMPANY1\Unused 39458.pdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}