$re = '/.*\\\\[\d\w]+ (?<InvoiceID>\d+)[ ]*(?<ExtraInfo>.*)\.(?<Ext>.*)$/m';
$str = 'I:\\ARInvoices\\COMPANY1\\Unused 39458 ExtraInfo.pdf
I:\\ARInvoices\\COMPANY1\\Unused 39458.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);