// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*\\[\d\w]+ (?<InvoiceID>\d+)[ ]*(?<ExtraInfo>.*)\.(?<Ext>.*)$").unwrap();
let string = "I:\\ARInvoices\\COMPANY1\\Unused 39458 ExtraInfo.pdf
I:\\ARInvoices\\COMPANY1\\Unused 39458.pdf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}