using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^-]|^)(1(?:-1)+)(?!-)";
string input = @"1-1-1 and 1-1-1-1-1 but not -1-1-1-1 or 1-1-1-1-
1-1-1
1-1-1-1-1
-1-1-1-1
1-1-1-1-";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}